Python学习

题目1439:Least Common Multiple WA解决

题目描述:
The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.
输入:
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 … nm where m is the number of integers in the set and n1 … nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.
输出:
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.
样例输入:
2
3 5 7 15
6 4 10296 936 1287 792 1
样例输出:
105
10296

思路:
WA半天,做到怀疑人生,最终花了我20个豆子解决,题目要求lie in the range of 32-bit integer.int是到2^32-1。int不够,要longlong才行。真的一个-1没看清,浪费了好多时间。

贴下代码:

#include<stdio.h> 
int lcm(long long a,long long b){
    long long m=a,n=b;
    while(b!=0){
        long long t=a%b;
        a=b;
        b=t;
    }
    return m*n/a;
}
int main(){
    int n,m;
    long long a,b;
    while(scanf("%d",&n)!=EOF){
        while(n-->0){
            scanf("%d%lld",&m,&a);
            for(int i=1;i<m;i++){
                scanf("%lld",&b);
                a=lcm(a,b);
            }   
            printf("%d\n",a);
        }
    }
    return 0;
}
/**************************************************************
    Problem: 1439
    User: WZDCJ0206
    Language: C++
    Result: Accepted
    Time:0 ms
    Memory:1020 kb
****************************************************************/
Be the First to comment.

Leave a Comment

您的电子邮箱地址不会被公开。

此站点使用Akismet来减少垃圾评论。了解我们如何处理您的评论数据